Rev Counter/Speedometer SIP

Has anybody worked out how to change the Speedo from KMPH to MPH?

The instructions are a bit confusing [:S]

The speedometer issue is sorted, just needed to adjust the cable position so it contacted both the indicator and drive pinon.

The rev counter is not indicating properly.  If I select reference "1" for a 1 cyl 2t engine, it reads about 4 times too high.  I did put in a resistor plug as the guide suggested. As mentioned reference "3" is close, but still reads high.  Is there a way to adjust the rev counter?

Hi !

 

Ok, so the tolerance in settin 3 is 400 rpms.

What tires exactly do you run ?

 

Cheers

Hello !

 

Can you tell me if you´ve tried it in all settings reg. the rpm display ?

If i understood right the reference 3 is the closest one ?

Can you also tell me what sparkplug you you use ?

 

Cheers

A new issue has developed with the rev counter.  When the scooter is shut down, the analog needle remains "stuck" at the center position of the scale.  When I start the scooter and the instrument powers up, the needle will cycle full scale both ways like it always did, but then seems to indicate about twice the actual RPM.  The didital RPM readout is normal.  Is there a way to reset the needle?

Yes, have tried all of the settings from .5 through 6.  As the setting number gets higher, the rpm indication gets lower as you would expect.  I would think setting 1 (1 cyl, 2t) would be correct but the indicated rpm is way too high.  On setting 3 the rpm is indicating 4600 for a speed in 4th gear at 45 mph (gps calibrated) with stock gearing.  Setting 4 gives 3400 rpm for 45 mph.  The calculation from scooterhelp.com indicates the rpm should be almost 4200.

    http://scooterhelp.com/tuning/vespa.gear.calc.html 

I'm using an NGK BR7ES spark plug with the Femsatronic ignition.

Yes.  From the main/basic function display (the one that has the odometer at the bottom) push the setting button for 3 seconds to go to the adjustment mode.  When it enters the adjustment mode, the numeral "1" should be flashing.  Push the button again for 3 seconds to get to the units.  Push the button once to switch from km/C to miles/F.  Then you can either let it time out and automatically go back to the function display or push the button again for 3 seconds to get the numeral "1" flashing again.  A one second button push will then take you to setting "2" which will be flashing. Keep going with the one second pushes to go to 3, 4, then back to the main function display.

 

My problem is getting the speed to display, as well as the rpm to indicate properly.  The speedometer cable turns properly when the front wheel turns, but the speed remains at "0"  regardless of the circumference and correction factor selected.  I'm wonder if the square drive end extending from the outer housing isn't long enough to turn the instrument's drive?  If I select the 2cycle/1 piston setting, the rpm is way too high.  The standard setting of "3" seems close based on sound in the mid range (Rally 200 w/ Femsatronic ignition) but too high at idle.  I'm using A/C and wonder if the voltage is too low even though I've converted to 12 volts?

Tires are Kenda K329, circumference 1339mm. (I did need to lower the speedo drive correction factor from 75 down to 71 to get the speed to read properly with a gps unit.)

I'm thinking the indicated rpm might be "close enough" on setting 3.  The actual digital readout reads lower than the analog needle looks.  I'm still curious why setting 1 doesn't seem to be the right one but will chalk that up as one of the great mysteries of the universe.  Thanks