pk 200 xxl

hey all i’ve recently put a standard p200 motor in one of my pk’s
was running great for about 1 mth but on a long drive recently she started back fireing through the exhaust
if i let off the throttle and then accelerated again,the short of the story is that now she will start but if i open the throttle she dies,but she will rev if i have the choke on(i had to drive home like this!)
now:
the exhaust is old standard and shite,
i dont have a snorkel on the carb,(sucking in dirt?)
i have rewired the stator(to mount the cdi under the seat,maybe the solder came loose on a connection?)
could any of the above contribute to the flamethrower??
if not anybody got some suggestions?a friend told me "your carb is f**ked,just get a new one"


p.s. thanks in advance guys!

thanks for all the help lads!
checked everything
got sorted, it was the carb,
i stuck a scoot-rs 24mm on her now
and she’s running great!

Nice! Good to hear

Have you tried the woodruff key?

can you strobe it? it will also show if the spark is breaking down

can you borrow a coil/ht lead/cap/ plug from a running scoot?

also if you need the choke to run, it would mean, it needs more fuel so ...is the filter blocked?  fuel starvation?

hard to help wiyh out being there but will try!

 

 

 

 

 

 

 

 

 

 

 

 

 

 

[quote user=„lilp41301“]hey all i’ve recently put a standard p200 motor in one of my pk’s
was running great for about 1 mth but on a long drive recently she started back fireing through the exhaust
if i let off the throttle and then accelerated again,the short of the story is that now she will start but if i open the throttle she dies,but she will rev if i have the choke on(i had to drive home like this!)
now:
the exhaust is old standard and shite,
i dont have a snorkel on the carb,(sucking in dirt?)
i have rewired the stator(to mount the cdi under the seat,maybe the solder came loose on a connection?)
could any of the above contribute to the flamethrower??
if not anybody got some suggestions?a friend told me "your carb is f**ked,just get a new one"


p.s. thanks in advance guys!
[/quote]

Hmm how is the carby seated? Maybe not sealing perfectly? Sounds like its leaning off heaps. Hows the jets and carb have you given them a flush/clean?

new gaskets on the carb and all cleaned still the same

Maybe try a new stator or one you can borrow from someone, I had that
happen to me once. Riding along and as you rev it out it would randomly
cut then pick up again, till one day eventually died. Replaced
everything/cleaned etc and found out to be stator.