Another t5 clutch problem

hi all
here goes
i got the following
standard t5 clutch basket
uprated springs
4plate clutch
21t drive
sip clutch bearing in one

put it all together adjust the cable so the lever can be pulled in and kickstart slips down when i put my foot on it
but it doesn’t engage the clucth when the engine is running put it into gear and it creeps forward
i tried adjusting the cable and the lever got so tight i had to use t2 hands then it went bang and i thought fook, cables snapped no its snapped the little lever pin in the clutch cover

i never haf this problem with my other clutches and its really getting annoying now i’ve had the clutch apart so many times checking this and thats

only thing new is 4 plates and the sip bearing

questin do you still have to put the cover on the clutch with the sip bearing or not
i could do with some quick advise as i’m about to get so p1ssed off with it i’m gonna set fire to the fooker

i really need to sort this asap as i want to get the engine running properly
thanks in advance


can you explain me better what this sip bearing thing is?

Ive never had an old style 4 plate clutch that worked without drag which is what you were having. 3 plate will be fine. Use strengthened springs if your motor is a bit fruity.

good to know you’ve solved it.

Hi is it a cosa style clutch and are they new plates? If its the old style clutch go back to 3 plate and just uprate the springs.

hi guys
i’ve gone back to the 3 plate clutch as i tried to sort it out about 6 times no luck

it’s early mk1 t5 so 3 plates has to be used

the sip bearing is the one that fits on the clucth arm and pushes onto the outer clutch basket